The Ranger Station Forums

The Ranger Station Forums (http://www.therangerstation.com/forums/index.php)
-   2.9 Liter Forum (http://www.therangerstation.com/forums/forumdisplay.php?f=65)
-   -   2.9 No Power (http://www.therangerstation.com/forums/showthread.php?t=26331)

DerangedRanger33 09-22-2008 03:05 PM

2.9 No Power
 
My truck has no power at all. its a 5 speed and when im in high rpms it makes a grindind noise that sounds terrible. it dosent do it when the clutch is pushed in and i rev it up to 4 or 5 k rpms. only when im in gear driving. its very slow up any and every hill and the fastest i can go on flats is 40 or 45.
any one have this problem? or hear of it before? any help would be greatly appriciated.
thanks

BlackBII 09-22-2008 03:12 PM

First thing to do is pull codes, see if it will tell you whats going on:
http://www.therangerstation.com/tech_library/OBD_I.html

Then check all the Basics: Fuel Filter, Fuel Pressure, Spark Plugs, Wires, Air Filter, Compression etc.

Make sure it is all in working order, may need a tuneup

Is it smoking at all?

Did this just happen or has it been steadily getting worse?

The grinding could be a bearing in the transmission.

DerangedRanger33 09-22-2008 03:21 PM

I just did a complete tune up on it. new plugs and wires. oil change. air filter. It seems to be getting plenty of fuel because it revs up fine in neutral

DerangedRanger33 09-24-2008 12:38 AM

anyone at all have this problem before?

89DangerRanger 09-24-2008 06:21 PM

ya mine does it 2, my trans. grinds in 4 because the syncros went out of it and mine doesn't have power going up hill ether, i did a full tune up and replaced the fuel pump, and changed the filter and nothing made it better and mine revs up fine in neutral, i think its just an underpowered engine pushin 30's

DerangedRanger33 09-25-2008 02:02 AM

oh ok thank you very much.

so do you think a rebuilt tranny would help at all?
or should i give up all hope with the 2.9?
Mine was super slow with my 33 12.50s!:sad:
its a little quicker now with my 31 10.50s
but still cant get out of its own way.
and cant top more than 50 mph on flat ground

DerangedRanger33 09-25-2008 02:07 AM

and it also dosent make the grinding nose when its cold

ranger 09-25-2008 07:45 PM

i dont have that problem and im running 31's like black said i would try pulling the codes it might be somthing more complicated than just the simple tune up stuf


All times are GMT -5. The time now is 09:53 PM.

1999-2018 / 959 Media LLC / All Rights Reserved