Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'PlumCrazy'
October 2014 OTOTM

Mini Truck Of The Month

'Ted R.'
October 2014 MTOTM
 

Go Back   The Ranger Station Forums > Engine & Transmission Forums > 4-bangers > 4-Cylinder (2001 & Newer)

Notices

Reply
 
Thread Tools Display Modes
Old 01-20-2012, 06:08 AM   #1
Tractorman86
New Member
 
Join Date: Jan 2012
Posts: 7
Vehicle Year: 2004
Vehicle Make: Ford
Vehicle Model: Ranger singlecab shortbed 2wd 2.3
Rep Power: 0
Tractorman86 is on a distinguished road
Default Duratec compatability

So I think the engine in my 04 is blown (possibly rod?) But I found a2010 for 950, will it work as a direct replacement? Thanks
__________________
2004 ranger 2.3duratec 5-speed singlecab shortbed 2wd filter box mod single 2.5"universal cat and 2.5"thrush turbo muffler. Black with black wheels and DARK tint
Tractorman86 is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 01-21-2012, 05:58 PM   #2
Tractorman86
New Member
 
Join Date: Jan 2012
Posts: 7
Vehicle Year: 2004
Vehicle Make: Ford
Vehicle Model: Ranger singlecab shortbed 2wd 2.3
Rep Power: 0
Tractorman86 is on a distinguished road
Default

well i'm still not sure what is going on... i pulled the valve cover in hopes i would find a broken cam or some such easy fix but I've still got nothing. the cams and chain look GREAT and all the springs and buckets move the way they should, so i put a compression gauge on it and #1 has 180psi after 3 revolutions #s 2,3&4 have between 210-240psi after 3 revolutions. i found this a little weird because the "knock" i heard sounded like it was from the back of the engine... i guess it is a bottom end problem after all?
__________________
2004 ranger 2.3duratec 5-speed singlecab shortbed 2wd filter box mod single 2.5"universal cat and 2.5"thrush turbo muffler. Black with black wheels and DARK tint
Tractorman86 is offline   Reply With Quote
Old 05-16-2012, 02:27 AM   #3
theturbokid83
New Member
 
theturbokid83's Avatar
 
Join Date: Feb 2012
Location: Ramona, CA
Posts: 9
Vehicle Year: 2008
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Every day driving. Mods include cold air intake, 2.5" cat back diablo tuner, 17X8 Mustang GT wheels.
Rep Power: 0
theturbokid83 is on a distinguished road
Default

Did you try a wet compression test on Cyl. one? If there is no real improvement of pressure, do a leak-down test. If it does jump a lot say 50+ psi you have shitty rings. If not, well that sucks. leak down, depends were you hear the air come out. intake=valve exhaust=valve crank case=really bad ring/piston failure. no matter what the heads comming off.
theturbokid83 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 09:06 AM.




1999-2014 / 959 Media LLC / All Rights Reserved