Home Ford Ranger Forum Builders Guide How To Tech Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals

 
Old 12-12-2017, 09:33 AM   #1
Okanaganranger
New Member
 
Join Date: Dec 2017
Posts: 3
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Okanaganranger is on a distinguished road
Default No spark help please

So my 1999 3.0 ranger decided it wanted to die on me last week, I got in it, turned it on, put it in reverse and got about 10 feet. It hasnít turned over since!! So far I have replaced

-ignition coil
-spark plugs
-spark plug wires
-crankshaft sensor
-camshaft sensor
-all the relays
-even tried a different ECM with pats bypassed

Still I am getting no spark to my plugs. I am getting power to the coil.

Help please!!!
Okanaganranger is offline   Reply With Quote
Advertisement (Not shown to 'Premium Members')
Old 12-12-2017, 10:10 AM   #2
91stranger
Member
 
91stranger's Avatar
 
Join Date: Jul 2010
Location: ohio
Posts: 252
Vehicle Year: 1999
Vehicle Make: FORD
Vehicle Model: RANGER EXT CAB 3.0
I use this vehicle for: daily driving
Rep Power: 16
91stranger is on a distinguished road
Default

Did you check your battery connections? if they are loose or corroded it wont start. I would start with the basics like the battery voltage and connections.
__________________
1999 ford ranger 4 door, 2wd, tow package, 3.0 auto trans. sweet ladder rack, daily driver.
91stranger is offline   Reply With Quote
Old 12-12-2017, 10:16 AM   #3
Okanaganranger
New Member
 
Join Date: Dec 2017
Posts: 3
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Okanaganranger is on a distinguished road
Default

Battery connections are all good. The engine cranks no problem. Itís getting fuel I hooked a pressure tester to the valve and itís getting fuel (brand new fuel pump) there is no codes that come up when I plug a reader in.
Okanaganranger is offline   Reply With Quote
Old 12-12-2017, 10:18 AM   #4
Rearanger
Member
 
Join Date: Feb 2008
Posts: 1,301
Vehicle Year: 2003
Vehicle Make: Ford
Vehicle Model: Ranger 3.0L
Rep Power: 22
Rearanger is on a distinguished road
Default

Quote:
Originally Posted by Okanaganranger View Post
Still I am getting no spark to my plugs. I am getting power to the coil.
Spark is created when power to the coil primary is switched on and off. The switching is done by the ECM grounding the coil power on/off.

You can usually check this switching with a test light blinking. I'd check the grounding wire connection to the ECM - maybe a broken wire?
__________________
2003 3.0L Long Box, 5spd Manual, 2wd, 3.73 LS,
P235/70R-16, Synthetic fluids, Dual by-pass oil filter system, 81.5k miles
Rearanger is offline   Reply With Quote
Old 12-14-2017, 12:47 AM   #5
Okanaganranger
New Member
 
Join Date: Dec 2017
Posts: 3
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Okanaganranger is on a distinguished road
Default

I have just rewired the grounds to both sensors now. Took the whole thing out and re ran the ground wires and still nothing.
Okanaganranger is offline   Reply With Quote
Old 12-14-2017, 06:11 AM   #6
Rearanger
Member
 
Join Date: Feb 2008
Posts: 1,301
Vehicle Year: 2003
Vehicle Make: Ford
Vehicle Model: Ranger 3.0L
Rep Power: 22
Rearanger is on a distinguished road
Default

Did you test for switching primary?
__________________
2003 3.0L Long Box, 5spd Manual, 2wd, 3.73 LS,
P235/70R-16, Synthetic fluids, Dual by-pass oil filter system, 81.5k miles
Rearanger is offline   Reply With Quote
Old 12-27-2017, 03:51 PM   #7
Ulrichbrett
New Member
 
Join Date: Dec 2017
Posts: 3
Vehicle Year: 1993
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Ulrichbrett is on a distinguished road
Default 93 no start!

I have a 93, 3.0 manual. I rebuilt the engine, put everything back together, now the fuel pump won't run, and I have no spark, I replaced the Icm and still have the same result, what's my options! Help please.
Ulrichbrett is offline   Reply With Quote
Old 12-27-2017, 04:24 PM   #8
Rearanger
Member
 
Join Date: Feb 2008
Posts: 1,301
Vehicle Year: 2003
Vehicle Make: Ford
Vehicle Model: Ranger 3.0L
Rep Power: 22
Rearanger is on a distinguished road
Default

Quote:
Originally Posted by Ulrichbrett View Post
what's my options! Help please.
Does this engine have a crank position sensor on the crank pulley?
__________________
2003 3.0L Long Box, 5spd Manual, 2wd, 3.73 LS,
P235/70R-16, Synthetic fluids, Dual by-pass oil filter system, 81.5k miles
Rearanger is offline   Reply With Quote
Old 12-27-2017, 04:41 PM   #9
Ulrichbrett
New Member
 
Join Date: Dec 2017
Posts: 3
Vehicle Year: 1993
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Ulrichbrett is on a distinguished road
Default

No it doesn't
Ulrichbrett is offline   Reply With Quote
Old 12-27-2017, 06:03 PM   #10
Ulrichbrett
New Member
 
Join Date: Dec 2017
Posts: 3
Vehicle Year: 1993
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Ulrichbrett is on a distinguished road
Default

No it doesn't
Ulrichbrett is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem from no spark to spark but no fuel. Danger-Ranger3 2.9 Liter Forum 0 04-27-2015 10:23 PM
problem from no spark to spark but no fuel. Danger-Ranger3 2.9 Liter Forum 0 04-27-2015 09:40 PM
Waste Spark and spark plugs RonD 4.0 Liter Forum 3 04-15-2015 12:22 PM
no spark at the spark plugs or distributor accarmonaa Need Urgent Help Fast! 9 02-28-2015 12:44 AM
Issues with spark on my Dura spark Danni84 Need Urgent Help Fast! 6 03-26-2014 09:40 PM




All times are GMT -5. The time now is 07:45 AM.




© 1999-2018 / 959 Media LLC / All Rights Reserved