Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'AgPete139'
September 2014 OTOTM

Mini Truck Of The Month

'alexp11'
September 2014 MTOTM
 

Go Back   The Ranger Station Forums > Suspension & Armor > 4X4 Suspensions

4X4 Suspensions For stock & off-road suspensions using stock & aftermarket parts (IE suspension kits). Forum sponsored by RCI Metalworks

Reply
 
Thread Tools Display Modes
Old 06-13-2011, 06:42 PM   #1
Holsenback
New Member
 
Holsenback's Avatar
 
Join Date: Jul 2010
Location: Kentuckcy
Posts: 23
Vehicle Year: 2003
Vehicle Make: Ford
Vehicle Model: Ranger FX4 Level II
Rep Power: 0
Holsenback is on a distinguished road
Default Death wobble

I have a 2003 FX4 Level II. I just got new BFG AT TA/ko's, and installed new lower ball joints, uppers were ok. I now have a severe wobble in the wheel. I've had the tires balanced 2 time and aligned 2 times.

Any ideas?
Holsenback is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 06-13-2011, 07:12 PM   #2
kennykenny
Member
 
kennykenny's Avatar
 
Join Date: Aug 2007
Location: Manahawkin, NJ
Posts: 998
Vehicle Year: 1998
Vehicle Make: Ford
Vehicle Model: Ranger Super Cab
I use this vehicle for: Driving
Rep Power: 16
kennykenny is on a distinguished road
Send a message via AIM to kennykenny
Default

Wheel bearing assembly with give you a nasty death wobble, check them.
kennykenny is offline   Reply With Quote
Old 06-13-2011, 09:53 PM   #3
Holsenback
New Member
 
Holsenback's Avatar
 
Join Date: Jul 2010
Location: Kentuckcy
Posts: 23
Vehicle Year: 2003
Vehicle Make: Ford
Vehicle Model: Ranger FX4 Level II
Rep Power: 0
Holsenback is on a distinguished road
Default

I'm also feeling vibration in the brake pedal along with a squeak when I slightly depress the pedal.
Holsenback is offline   Reply With Quote
Old 06-13-2011, 10:24 PM   #4
wrecking-crew
Member
 
wrecking-crew's Avatar
 
Join Date: Sep 2008
Location: dirty jersey
Posts: 2,807
Vehicle Year: 06 chevy
Vehicle Make: 88 ranger
Vehicle Model: 83 ranger 66 f100
Rep Power: 21
wrecking-crew is just really nicewrecking-crew is just really nicewrecking-crew is just really nicewrecking-crew is just really nice
Send a message via AIM to wrecking-crew
Default

Sounds like a wheel hub is worn out and possibly wore the brakes . Check those.
__________________
-----The Black Bomb-----
Quote:
Originally Posted by RumpRangerSTX
new jersey home of thei love it
Quote:
Originally Posted by adsm08 View Post
My kids are gonna be able to count from 7 to 24 before they can walk.
"Kid, daddy needs the 13mm wrench."
wrecking-crew is offline   Reply With Quote
Old 02-06-2012, 01:09 PM   #5
Mrnicks
Junior Member
 
Join Date: Sep 2007
Posts: 35
Vehicle Year: 99" Ranger 4.0L
I use this vehicle for: 99" Ranger 4.0L Straight pipes, K&N cold air, rear locker, 33"x12.5" bfg's and TSL's 3"body and 2"s
Rep Power: 15
Mrnicks is on a distinguished road
Default

What was the conclusion to this? I have a similar problem.
Mrnicks is offline   Reply With Quote
Old 02-16-2012, 10:45 AM   #6
Mrnicks
Junior Member
 
Join Date: Sep 2007
Posts: 35
Vehicle Year: 99" Ranger 4.0L
I use this vehicle for: 99" Ranger 4.0L Straight pipes, K&N cold air, rear locker, 33"x12.5" bfg's and TSL's 3"body and 2"s
Rep Power: 15
Mrnicks is on a distinguished road
Default

Try to bleed your steering system. That was my problem. With the truck running and the front end off the ground I turned the wheel almost lock to lock about twenty times. Most of the shake went away after that. Then after driving it for a few days it's all gone.

Hope this helps. Maybe it does maybe not. It really through me for a loop when I discovered to be my problem.
Mrnicks is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 06:53 AM.




1999-2014 / 959 Media LLC / All Rights Reserved