Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'RICO9'
July 2014 OTOTM

Mini Truck Of The Month

'Cole' Dave'
July 2014 MTOTM
 
Old 07-20-2011, 11:05 PM   #1
idriveafordranger94
Member
 
idriveafordranger94's Avatar
 
Join Date: Mar 2008
Location: Hartville, Ohio
Posts: 272
Vehicle Year: 2009/1994/1988
Vehicle Make: Ford
Vehicle Model: Ranger FX4/Ranger/Bronco Fullsize
I use this vehicle for: Everything a man could ask for
Rep Power: 13
idriveafordranger94 is on a distinguished road
Default '94 2.3L - One Coil Pack Not Getting Power

Hey guys - my problem is back. My '94 Ranger that I picked up cheap to fix and sell has given me a problem I can't identify. The truck will be running fine, then all of a sudden - no power, almost stalls. Then just like that, it'll run fine. I discovered that one of the coil packs is not producing spark, so the truck starts running like crap. Both coils are good. Obviously a spark issue. Help guys, I need to sell this truck!
__________________
2009 Ford Ranger FX4 4.0L 5 speed manual
1994 Ford Ranger XLT Ext. Cab 4.0L V6
1988 Ford Bronco Eddie Bauer Fullsize 5.0L 302 V8
"There's something women like about a pickup man"
idriveafordranger94 is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 07-20-2011, 11:51 PM   #2
scotts90ranger
Member
 
scotts90ranger's Avatar
 
Join Date: Feb 2001
Location: Salem Oregon
Posts: 2,945
Vehicle Year: 1990
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: holding down the driveway
Rep Power: 35
scotts90ranger is a jewel in the roughscotts90ranger is a jewel in the roughscotts90ranger is a jewel in the rough
Default

When it acts up, take the ignition module to autozone or something and have it checked, it's about the only other part of the ignition system
__________________
converted to 4x4, turbo'd the 2.3, 6" lift with 35's and 5.13 gears!
Send e-mail instead of PM, box full...
scotts90ranger is offline   Reply With Quote
Old 07-21-2011, 10:59 PM   #3
Bryan22
Member
 
Bryan22's Avatar
 
Join Date: May 2008
Location: So-Cal babay
Posts: 1,611
Vehicle Year: 94 extd
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: fun, dd.
Rep Power: 16
Bryan22 is on a distinguished road
Default

Just an FYI, one pack doesn't spark when you're trying to start it, so if you found a pack had no spark with the truck not running, it's normal.
Bryan22 is offline   Reply With Quote
Old 07-23-2011, 05:59 AM   #4
modelageek
Member
 
modelageek's Avatar
 
Join Date: Jan 2009
Location: Boston, MA
Posts: 2,094
Vehicle Year: 2004
Vehicle Make: Ford
Vehicle Model: Ext Cab, Edge, 2WD, M5OD, 4WABS, AC, 112k.
Rep Power: 16
modelageek will become famous soon enough
Default

Quote:
Originally Posted by idriveafordranger94 View Post
Hey guys - my problem is back. My '94 Ranger that I picked up cheap to fix and sell has given me a problem I can't identify. The truck will be running fine, then all of a sudden - no power, almost stalls. Then just like that, it'll run fine. I discovered that one of the coil packs is not producing spark, so the truck starts running like crap. Both coils are good. Obviously a spark issue. Help guys, I need to sell this truck!
Quote:
Originally Posted by scotts90ranger View Post
When it acts up, take the ignition module to autozone or something and have it checked, it's about the only other part of the ignition system
Quote:
Originally Posted by Bryan22 View Post
Just an FYI, one pack doesn't spark when you're trying to start it, so if you found a pack had no spark with the truck not running, it's normal.
Bryon had a nice observation about the exhaust side not always firing........my guess is the primary coil is the one that is not receiving the power and I agree that it is most likely the ICM
__________________
2004 Ford Ranger Edge, ext cab, 2wd, 3.0, 5 speed, 112,000, AC.

1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD)
modelageek is offline   Reply With Quote
Old 07-23-2011, 12:54 PM   #5
scotts90ranger
Member
 
scotts90ranger's Avatar
 
Join Date: Feb 2001
Location: Salem Oregon
Posts: 2,945
Vehicle Year: 1990
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: holding down the driveway
Rep Power: 35
scotts90ranger is a jewel in the roughscotts90ranger is a jewel in the roughscotts90ranger is a jewel in the rough
Default

Quote:
Originally Posted by modelageek View Post
Bryon had a nice observation about the exhaust side not always firing........my guess is the primary coil is the one that is not receiving the power and I agree that it is most likely the ICM
the intake side is secondary, I'm running my truck only on the exhaust side with the 4 plug turbo engine with DIS
__________________
converted to 4x4, turbo'd the 2.3, 6" lift with 35's and 5.13 gears!
Send e-mail instead of PM, box full...
scotts90ranger is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 05:23 PM.




1999-2014 / 959 Media LLC / All Rights Reserved