Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'Kona'
June 2014 OTOTM

Mini Truck Of The Month

'Dazzlin' Dave'
June 2014 MTOTM
 

Go Back   The Ranger Station Forums > Truck Discussions > Mazda B-Series Specific

Mazda B-Series Specific Addressing issues specific to the Mazda B-Series trucks

Reply
 
Thread Tools Display Modes
Old 01-21-2012, 01:01 PM   #1
Raw16057
Junior Member
 
Join Date: Aug 2009
Location: Baden PA
Posts: 55
Vehicle Year: 2006
Vehicle Make: Ford
Vehicle Model: Ranger XLT
I use this vehicle for: daily driver
Rep Power: 10
Raw16057 is on a distinguished road
Default heater blower not working

Hi, i have a 94 B4000 ext cab 4.0 5 speed 4x4 with air and my heater blower is about gone. Anyone here have an extra one they would like to sell? PM me.
Raw16057 is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 02-12-2012, 01:38 PM   #2
02_B4000_4x4
New Member
 
Join Date: Feb 2012
Posts: 6
Vehicle Year: 2002
Vehicle Make: Mazda
Vehicle Model: B4000 4x4
Rep Power: 0
02_B4000_4x4 is on a distinguished road
Default

Quote:
Originally Posted by Raw16057 View Post
Hi, i have a 94 B4000 ext cab 4.0 5 speed 4x4 with air and my heater blower is about gone. Anyone here have an extra one they would like to sell? PM me.
I just bought a 02 B4000 4x4 Automatic and the number 2 fuse in the fuse box controls the O/D, Daytime Running Lights, Blower motor, Reverse Lights, the Air Bags, and i think there is one more. I am trying to look for help too. Mine lasts for about 15 minutes blower motor on full before it blows the fuse. I am looking for any advice from anyone.
02_B4000_4x4 is offline   Reply With Quote
Old 02-13-2012, 07:49 PM   #3
sparkola
New Member
 
Join Date: Feb 2011
Posts: 7
Vehicle Year: 2000
Vehicle Make: Mazda
Vehicle Model: B4000
Rep Power: 0
sparkola is on a distinguished road
Default

Do they only work when the fan speed selector is on high? Its the resistor pack located in the blower motor housing under the hood. costs about 30 bucks to replace and about 30 mins with the right small sockets/nut drivers and some patience.
sparkola is offline   Reply With Quote
Old 02-19-2012, 02:40 PM   #4
Raw16057
Junior Member
 
Join Date: Aug 2009
Location: Baden PA
Posts: 55
Vehicle Year: 2006
Vehicle Make: Ford
Vehicle Model: Ranger XLT
I use this vehicle for: daily driver
Rep Power: 10
Raw16057 is on a distinguished road
Default blower motor conclusion

hello, got it fixed. went to the junkyard and bought another motor that had good brushes, put it on and now it works like new.
Raw16057 is offline   Reply With Quote
Old 02-19-2012, 03:42 PM   #5
Mark_88
Einstein I'm NOT
 
Mark_88's Avatar
 
Join Date: Aug 2007
Location: Uxbridge, Ontario
Posts: 15,158
Vehicle Year: 1988
Vehicle Make: Ford
Vehicle Model: Multi-year Ranger
I use this vehicle for: Space travel
Rep Power: 85
Mark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond reputeMark_88 has a reputation beyond repute
Default

Quote:
Originally Posted by 02_B4000_4x4 View Post
I just bought a 02 B4000 4x4 Automatic and the number 2 fuse in the fuse box controls the O/D, Daytime Running Lights, Blower motor, Reverse Lights, the Air Bags, and i think there is one more. I am trying to look for help too. Mine lasts for about 15 minutes blower motor on full before it blows the fuse. I am looking for any advice from anyone.
If you're blowing fuses you need to check back on any recently installed parts...it's probably not the heater fan that is blowing the fuse, but something else on the same circuit...if you happen to have installed a new stereo or modified any accessories that would be the place to start...

You may also have a bad ground on something...check under the hood for loose connections...

Quote:
Originally Posted by Raw16057 View Post
hello, got it fixed. went to the junkyard and bought another motor that had good brushes, put it on and now it works like new.

Cool...I did mine last summer...nice to know it's such an easy fix...and that you can still buy new blowers if needed...and also that the parts are interchangeable from the 80s right up to the late 90s on these trucks...
__________________

Rome and my Ranger were not built in a day...
Mark_88 is offline   Reply With Quote
Old 03-19-2012, 07:48 PM   #6
02_B4000_4x4
New Member
 
Join Date: Feb 2012
Posts: 6
Vehicle Year: 2002
Vehicle Make: Mazda
Vehicle Model: B4000 4x4
Rep Power: 0
02_B4000_4x4 is on a distinguished road
Default

Quote:
Originally Posted by Mark_88 View Post
If you're blowing fuses you need to check back on any recently installed parts...it's probably not the heater fan that is blowing the fuse, but something else on the same circuit...if you happen to have installed a new stereo or modified any accessories that would be the place to start...

You may also have a bad ground on something...check under the hood for loose connections...
I found the problem. Its an auto and where the wires for the O/D leave the shifter into the coloum, the rubber coating on the outside rubbed off leaving the wires exposed, and when ever I shifted, it would rub against the metal on the coloum causing it to ground out. Thanks for the info though.
02_B4000_4x4 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 11:29 PM.




1999-2014 / 959 Media LLC / All Rights Reserved