Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'PlumCrazy'
October 2014 OTOTM

Mini Truck Of The Month

'Ted R.'
October 2014 MTOTM
 

Go Back   The Ranger Station Forums > Styling & Electrical > Misc Electrical & Gauges

Notices

Misc Electrical & Gauges Post your speedometer, gauges, interior and non audio/video questions here.

Reply
 
Thread Tools Display Modes
Old 09-20-2007, 10:15 AM   #1
noog67
New Member
 
noog67's Avatar
 
Join Date: Aug 2007
Location: NE Pa.
Posts: 16
Vehicle Year: 2000
Vehicle Make: FORD
Vehicle Model: RANGER SC
Rep Power: 0
noog67 is on a distinguished road
Default ecc fuse keeps blowin

Need a little help if any one can. I have a 94 scab 4.0 4x4 ranger and i keep blowin the ecc fuse under the hood . I changed the relay and fuel pump (thought it was the problem but it is not) . I just cant find a short . Anyone ever have a problem like this before? I dont want to change the harness but I will if i have to . I really love this truck it is the 3rd ranger i have owned and i never have been stummped before this. Any help would be great.
noog67 is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 09:17 PM.




1999-2014 / 959 Media LLC / All Rights Reserved