Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'AgPete139'
September 2014 OTOTM

Mini Truck Of The Month

'alexp11'
September 2014 MTOTM
 
Old 09-22-2008, 03:05 PM   #1
DerangedRanger33
New Member
 
Join Date: Sep 2008
Location: York, Pennsylvania
Posts: 9
Vehicle Year: 1989
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Everything
Rep Power: 0
DerangedRanger33 is on a distinguished road
Angry 2.9 No Power

My truck has no power at all. its a 5 speed and when im in high rpms it makes a grindind noise that sounds terrible. it dosent do it when the clutch is pushed in and i rev it up to 4 or 5 k rpms. only when im in gear driving. its very slow up any and every hill and the fastest i can go on flats is 40 or 45.
any one have this problem? or hear of it before? any help would be greatly appriciated.
thanks
DerangedRanger33 is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 09-22-2008, 03:12 PM   #2
BlackBII
Cheaf of Grammor Poleace

 
BlackBII's Avatar
 
Join Date: Aug 2007
Location: Orem UT
Posts: 6,442
Vehicle Year: 1989
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Getting irritated
Rep Power: 38
BlackBII has much to be proud ofBlackBII has much to be proud ofBlackBII has much to be proud ofBlackBII has much to be proud ofBlackBII has much to be proud ofBlackBII has much to be proud ofBlackBII has much to be proud ofBlackBII has much to be proud ofBlackBII has much to be proud of
Default

First thing to do is pull codes, see if it will tell you whats going on:
http://www.therangerstation.com/tech_library/OBD_I.html

Then check all the Basics: Fuel Filter, Fuel Pressure, Spark Plugs, Wires, Air Filter, Compression etc.

Make sure it is all in working order, may need a tuneup

Is it smoking at all?

Did this just happen or has it been steadily getting worse?

The grinding could be a bearing in the transmission.
__________________
I hate all RBV's, especially the ones I own.

Last edited by BlackBII; 09-22-2008 at 03:15 PM.
BlackBII is offline   Reply With Quote
Old 09-22-2008, 03:21 PM   #3
DerangedRanger33
New Member
 
Join Date: Sep 2008
Location: York, Pennsylvania
Posts: 9
Vehicle Year: 1989
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Everything
Rep Power: 0
DerangedRanger33 is on a distinguished road
Default

I just did a complete tune up on it. new plugs and wires. oil change. air filter. It seems to be getting plenty of fuel because it revs up fine in neutral
DerangedRanger33 is offline   Reply With Quote
Old 09-24-2008, 12:38 AM   #4
DerangedRanger33
New Member
 
Join Date: Sep 2008
Location: York, Pennsylvania
Posts: 9
Vehicle Year: 1989
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Everything
Rep Power: 0
DerangedRanger33 is on a distinguished road
Default

anyone at all have this problem before?
DerangedRanger33 is offline   Reply With Quote
Old 09-24-2008, 06:21 PM   #5
89DangerRanger
Junior Member
 
89DangerRanger's Avatar
 
Join Date: Mar 2008
Location: Eldridge IA
Posts: 75
Vehicle Year: 1979/ 2003
Vehicle Make: Ford
Vehicle Model: F150 custom/ svt focus
I use this vehicle for: winter beater and mud truck/ dd driver and ricer burner
Rep Power: 14
89DangerRanger is on a distinguished road
Default

ya mine does it 2, my trans. grinds in 4 because the syncros went out of it and mine doesn't have power going up hill ether, i did a full tune up and replaced the fuel pump, and changed the filter and nothing made it better and mine revs up fine in neutral, i think its just an underpowered engine pushin 30's
89DangerRanger is offline   Reply With Quote
Old 09-25-2008, 02:02 AM   #6
DerangedRanger33
New Member
 
Join Date: Sep 2008
Location: York, Pennsylvania
Posts: 9
Vehicle Year: 1989
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Everything
Rep Power: 0
DerangedRanger33 is on a distinguished road
Default

oh ok thank you very much.

so do you think a rebuilt tranny would help at all?
or should i give up all hope with the 2.9?
Mine was super slow with my 33 12.50s!
its a little quicker now with my 31 10.50s
but still cant get out of its own way.
and cant top more than 50 mph on flat ground
DerangedRanger33 is offline   Reply With Quote
Old 09-25-2008, 02:07 AM   #7
DerangedRanger33
New Member
 
Join Date: Sep 2008
Location: York, Pennsylvania
Posts: 9
Vehicle Year: 1989
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Everything
Rep Power: 0
DerangedRanger33 is on a distinguished road
Default

and it also dosent make the grinding nose when its cold
DerangedRanger33 is offline   Reply With Quote
Old 09-25-2008, 07:45 PM   #8
ranger
Member
 
Join Date: May 2008
Location: Pittsburgh,Pa
Posts: 378
Vehicle Year: 1988
Vehicle Make: ford
Vehicle Model: ranger
I use this vehicle for: waisting gas and money
Rep Power: 13
ranger is on a distinguished road
Send a message via AIM to ranger
Default

i dont have that problem and im running 31's like black said i would try pulling the codes it might be somthing more complicated than just the simple tune up stuf
ranger is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 07:10 AM.




1999-2014 / 959 Media LLC / All Rights Reserved