Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'PlumCrazy'
October 2014 OTOTM

Mini Truck Of The Month

'Ted R.'
October 2014 MTOTM
 

Go Back   The Ranger Station Forums > Engine & Transmission Forums > Transmissions

Notices

Reply
 
Thread Tools Display Modes
Old 11-22-2009, 09:39 PM   #1
eric
New Member
 
Join Date: Jan 2009
Posts: 22
Rep Power: 0
eric is on a distinguished road
Default 2001 ranger bleeding clutch

I was told by a ford tech that the only was to bleed is to open reservoir, leave fluid in , pump clutch 15x then hold clutch petal down 10 seconds. Repeat for 30 minutes. I have done this and clutch works great for about 15 minutes then I start losing it again. I had a slave cylinder put in 10 months ago. Could this be a case of lots of air in system and needing a heavy bleed?

Thanks in advance
eric is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 08:14 AM.




1999-2014 / 959 Media LLC / All Rights Reserved