Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'AgPete139'
September 2014 OTOTM

Mini Truck Of The Month

'alexp11'
September 2014 MTOTM
 

Go Back   The Ranger Station Forums > Styling & Electrical > Heating & Air Conditioning

Reply
 
Thread Tools Display Modes
Old 12-11-2007, 10:10 AM   #1
Carl
New Member
 
Join Date: Dec 2007
Posts: 7
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Carl is on a distinguished road
Default Replacing Thermostat in 1999 2.5L 4-cyl XLT

My temperature gauge won't even peek above the coolest temp and my engine threw a code last week that said 'Low coolant temp for closed loop operation'. I want to replace my thermostat, but it doesn't reside where most authorities say it should...where the top hose enters the engine.

Can anyone tell me where to find the thermostat on my truck? The fix seems simple, so I think I can handle it...especially since the shop quoted me $170 to do it.

Thanks in advance for your help.

Carl
Carl is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 12-11-2007, 11:10 AM   #2
offroadranger
Member
 
Join Date: Nov 2007
Posts: 130
Rep Power: 15
offroadranger is on a distinguished road
Default

It is in fact under the upper radiator hose. You have to remove the fitting that the hose attaches too from the engine.
offroadranger is offline   Reply With Quote
Old 12-11-2007, 11:15 AM   #3
Carl
New Member
 
Join Date: Dec 2007
Posts: 7
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Carl is on a distinguished road
Default

Quote:
Originally Posted by offroadranger View Post
It is in fact under the upper radiator hose. You have to remove the fitting that the hose attaches too from the engine.
And all I'll have to do is remove the bolts to remove the housing, replace the thermostat and gasket, seal up and refit the housing with adhesive, and connect the hose back?

Seems easy enough. Thanks for the info.
Carl is offline   Reply With Quote
Old 12-11-2007, 11:28 AM   #4
MAKG
RBV Technical Advisor
 
Join Date: Aug 2007
Location: California central coast
Posts: 4,640
Vehicle Year: 1991
Vehicle Make: Ford
Vehicle Model: Explorer
Rep Power: 24
MAKG will become famous soon enough
Default

It shouldn't be necessary to glue the housing in, and if you do, the next guy to change that thermostat will curse your name and your descendents. Even if it's you.

Thermostats come either with a gasket, or usually with a slotted O-ring that fits around the thermostat body. Just replace that.

I recommend replacing thermostat (and water pump) bolts with stainless whenever they are removed. It sure makes subsequent removals nicer.
__________________

1990 VW Jetta GL, 1.8L 8V gasoline engine, manual transmission, painted in oxidized red paint and ponderosa pine sap, unknown mileage.

1991 Exploder, 4.0L, M5OD-R1 manual transmission, electronic BW1354 transfer case, 3.54 gears, 31 inch tires, icky two-tone blue paint with little clear coat, 230K miles.

1972 Chevy C-10, 250 I-6, SM465 (2WD) four-on-the-floor, 3.73 gears in a GM 12-bolt, puke green with a white cab. The "4 wheeled trash can," with x70K miles. x is probably 2.
MAKG is offline   Reply With Quote
Old 12-11-2007, 02:44 PM   #5
Carl
New Member
 
Join Date: Dec 2007
Posts: 7
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Carl is on a distinguished road
Default

So it really is that simple? Disconnect the hose form the radiator to the engine, under which I will find the thermostat housing, unscrew the bolts holding down the housing, remove the thermostat, replace it with the new one and then put it all back together?

Thanks for your help. The $170 really seems like a ripoff now.
Carl is offline   Reply With Quote
Old 12-11-2007, 02:58 PM   #6
MAKG
RBV Technical Advisor
 
Join Date: Aug 2007
Location: California central coast
Posts: 4,640
Vehicle Year: 1991
Vehicle Make: Ford
Vehicle Model: Explorer
Rep Power: 24
MAKG will become famous soon enough
Default

To be honest, that pretty much describes a transmission replacement as well. As well as quite a lot of other things.

The devil is in the details. What do you need to remove to get at the thermostat housing bolts? Sometimes it's nothing. But not always. On my Prizm, I have to remove the airbox. On my 4.0L, the serpentine belt tensioner has to come off. Well, you get the idea. $170 does seem a bit steep, though.

FYI, you certainly are going to have to drain some of the coolant (not very much, though), or you're going to make a mess. However, now might be a good time for a flush. Be careful about spilling coolant; it tastes sweet and will attract small animals and small children. It's moderately toxic.
__________________

1990 VW Jetta GL, 1.8L 8V gasoline engine, manual transmission, painted in oxidized red paint and ponderosa pine sap, unknown mileage.

1991 Exploder, 4.0L, M5OD-R1 manual transmission, electronic BW1354 transfer case, 3.54 gears, 31 inch tires, icky two-tone blue paint with little clear coat, 230K miles.

1972 Chevy C-10, 250 I-6, SM465 (2WD) four-on-the-floor, 3.73 gears in a GM 12-bolt, puke green with a white cab. The "4 wheeled trash can," with x70K miles. x is probably 2.
MAKG is offline   Reply With Quote
Old 12-11-2007, 03:16 PM   #7
Carl
New Member
 
Join Date: Dec 2007
Posts: 7
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Carl is on a distinguished road
Default

Well, I just had the radiator replaced very recently, so I don't think it's time for a flush. I'll just let it cool down and drain enough to where the hose doesn't drain coolant everywhere.

As for the bolts, it seems like it should be pretty easy. The spot where the hose hits the engine is right in front, on top, so if I remove the hose, the housing should be right under there, correct?

Again, thanks for the help.

Last edited by Carl; 12-11-2007 at 03:19 PM.
Carl is offline   Reply With Quote
Old 12-11-2007, 04:22 PM   #8
offroadranger
Member
 
Join Date: Nov 2007
Posts: 130
Rep Power: 15
offroadranger is on a distinguished road
Default

Quote:
Originally Posted by Carl View Post
Well, I just had the radiator replaced very recently, so I don't think it's time for a flush. I'll just let it cool down and drain enough to where the hose doesn't drain coolant everywhere.

As for the bolts, it seems like it should be pretty easy. The spot where the hose hits the engine is right in front, on top, so if I remove the hose, the housing should be right under there, correct?

Again, thanks for the help.

Thats correct. Unplug the connectors for the temp sensors and unbolt the housing. It uses an o ring. No RTV, adhesive or anything is needed. You can only get that o ring(as far as I know) from ford. I re-used mine as it was in good shape and it was fine.

One thing I do remember from when I changed mine was the thermostat is oval. Autozone may try and sell you a round one becuase thats what thier computer says it uses, they are wrong. Its oval. You may save yourself some trouble by buying your replacement thermostat from a ford dealer.
offroadranger is offline   Reply With Quote
Old 12-12-2007, 09:05 AM   #9
Carl
New Member
 
Join Date: Dec 2007
Posts: 7
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
Carl is on a distinguished road
Default

Quote:
Originally Posted by offroadranger View Post
Thats correct. Unplug the connectors for the temp sensors and unbolt the housing. It uses an o ring. No RTV, adhesive or anything is needed. You can only get that o ring(as far as I know) from ford. I re-used mine as it was in good shape and it was fine.

One thing I do remember from when I changed mine was the thermostat is oval. Autozone may try and sell you a round one becuase thats what thier computer says it uses, they are wrong. Its oval. You may save yourself some trouble by buying your replacement thermostat from a ford dealer.
Odd. I got a rubber O ring from Autozone. They assured me that the round thermostat was the correct one, and that thye have sold many round thermostats that have not been returned.

Anyone esle?
Carl is offline   Reply With Quote
Old 12-12-2007, 10:19 AM   #10
offroadranger
Member
 
Join Date: Nov 2007
Posts: 130
Rep Power: 15
offroadranger is on a distinguished road
Default

Quote:
Originally Posted by Carl View Post
Odd. I got a rubber O ring from Autozone. They assured me that the round thermostat was the correct one, and that thye have sold many round thermostats that have not been returned.

Anyone esle?
I knew it!!!! haha. Well I suppose its POSSIBLE ford put two different thermos in but I HIGHLY doubt it. That would mean two different housings as well. My 1999 2.5 uses an oval thermo, I promise.
offroadranger is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 12:13 AM.




1999-2014 / 959 Media LLC / All Rights Reserved