1990 Ranger XLT 4X4 Not Working


Greenwoodguy456

New member
Joined
Jun 22, 2019
Messages
1
Reaction score
0
Points
1
Location
Missouri
Vehicle Year
1990
Make / Model
Ford Ranger XLT
Transmission
Manual
The ranger had the electric switch, once I press the button the 4X4 light comes on and I hear the Module click behind me. It will not kick into 4 wheel drive and the passenger side hub ticks. Mind you it will go in the low range gears but not 4 wheel drive. Does anyone know what it is??

Thanks,
Brent
 


Rock Auto 5% Discount Code: 173A8B749AB83C Expires: January 1, 2020

Uncle Gump

Well-known member
Supporting Member
Joined
Sep 17, 2018
Messages
1,837
Reaction score
903
Points
113
Location
Plano IL
Vehicle Year
2006
Make / Model
Ford
Engine Size
4.0L
Transmission
Automatic
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
Sounds like a bad hub...
 

RonD

Well-known member
Joined
Jun 2, 2012
Messages
14,074
Reaction score
774
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Yes, +1 ^^^

Welcome to TRS :)

Ranger 4x4s have an OPEN front differential, so if one of the hubs doesn't lock then no 4WD, the ticking noise when moving means one hub is not fully engaged

I assume you have "automatic hubs", which can break, manual hubs are better

You can pull the wheel off and the hub cover make sure its not packed with grease, if so clean off as much as you can and used some motor oil for lube, axle grease is too thick and makes hubs stick
 


Top