new rebuild problems


akmade65

New member
Joined
Jan 16, 2016
Messages
9
Reaction score
2
Points
3
Vehicle Year
1996
Make / Model
Ranger Splash
Engine Size
3.8 SC
Transmission
Automatic
2WD / 4WD
2WD
Hi I bought a 85 B2 in pieces and have rebuilt the 2.8 and have gotten back together. After only about 10 min it started blowing antifreeze out the tail pipe. I hoped it was leftover in the exhaust but after 30 min its still doing it. This is my first 2.8 and did not get to take it apart so I could be missing something. block and heads were surfaced for good sealing, heads were pressure checked. engine runs real good otherwise. Has anyone had trouble with the intake gaskets not sealing? Thanx for any help Tim
 


Rock Auto 5% Discount Code: 173A8B749AB83C Expires: January 1, 2020

rusty ol ranger

2.9L Mafia-Don
Supporting Member
Joined
Sep 22, 2007
Messages
5,213
Reaction score
1,088
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
2.9L
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
Did they magnaflux the heads to check for cracks? The 2.9 is prone to it, im not sure about the 2.8 but its not a imagination stretch.

Other then that it could be a slightly warped intake manifold...was it lathed down before installation? Ive had this happen on quite w few V8s.

Heads torqued properly?
 

akmade65

New member
Joined
Jan 16, 2016
Messages
9
Reaction score
2
Points
3
Vehicle Year
1996
Make / Model
Ranger Splash
Engine Size
3.8 SC
Transmission
Automatic
2WD / 4WD
2WD
Heads were checked, intake is flat with proper gap at front and rear ,torque is good. Pulled intake and gaskets did not seal. The surface was too smooth. Fixed it now just waiting for rain to stop to put it back together. Thank You Tim
 


Top