View Single Post
Old 08-28-2018, 09:37 AM   #5
chewy012
Member
 
chewy012's Avatar
 
Join Date: Jan 2016
Location: Colorado Springs, CO
Posts: 428
Vehicle Year: 1992
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: High Performance Commute
Rep Power: 8
chewy012 has a spectacular aura aboutchewy012 has a spectacular aura about
Default

If anyone is still listening, I just replaced the clutch and slave/tb, and its not feeling right. The pedal feels fully bled, in that, the pedal is firm with the hydraulic line disconnected, and prying between the tb and clutch fingers is tight. I've gone through bleed procedure about 6 times since the I plugged the line back in. The pedal feels a lot easier than it did with the last clutch, and it releases way at the end of the pedal. With my arm I feel the consistent spring back force all the way through the pedal, but it does feel like anything with my foot.

My book said 20-29 ft-lbs for the pressure plate, and I did 10 than 20 and stopped there as the bolts felt tight.

Do I need to tighten it down more?

I drove it to work this morning, it feels ok... Seems to shift gears well enough, but theres no feel to the pedal. And the end of the pedal grab I don't like. The clutch was the M-PACT 07097ST1 on rockauto, with which has almost a full face of material. The old one had only had about a 1 inch ring of material around the outside.

Also, I noticed with my foot on the brake, it starts to pull the idle down at about 3/4 and I can bring it to a stall, but again, it's like there's nothing there.

I've never had a clutch feel like this

Sent from my VS988 using Tapatalk
__________________
4.0L OHV, M5OD, 3.08 Rear, 205/75R14, K&N, Stock.
chewy012 is offline   Reply With Quote