engine ticking on cold startup...


jamessmith20

New member
Joined
Oct 1, 2007
Messages
5
Reaction score
0
Points
0
Age
34
Vehicle Year
1994
Make / Model
Mazda
Transmission
Manual
I have a 94 Mazda B4000 it sat in my driveway for a month and now when i start it up it has a loud ticking, but it goes away when the truck warms up alil. it had a miss fire code before i let it sit....what could this be??
 


Rock Auto 5% Discount Code: CFB3B5F7F32B37 Expires: March 30, 2020

kunar

Forum Staff Member
Forum Moderator
Supporting Member
Article Contributor
Joined
Jun 10, 2003
Messages
4,054
Reaction score
55
Points
48
Age
32
Location
Toledo, Ohio
Vehicle Year
1987
Make / Model
Ford
Engine Size
2.3t
Transmission
Manual
what engine is it?
 

jamessmith20

New member
Joined
Oct 1, 2007
Messages
5
Reaction score
0
Points
0
Age
34
Vehicle Year
1994
Make / Model
Mazda
Transmission
Manual
I have a 94 Mazda B4000 it sat in my driveway for a month and now when i start it up it has a loud ticking, but it goes away when the truck warms up alil. it had a miss fire code before i let it sit....what could this be??
 

jamessmith20

New member
Joined
Oct 1, 2007
Messages
5
Reaction score
0
Points
0
Age
34
Vehicle Year
1994
Make / Model
Mazda
Transmission
Manual
its the 4.0L
 

snake

New member
Joined
Aug 6, 2007
Messages
1,388
Reaction score
4
Points
0
Location
canyon lake tx
Vehicle Year
2011
Make / Model
Ford
Engine Size
3.5
Transmission
Automatic
Try some marvel's mystery oil in both the gas and oil. Sounds like a lifter is losing pressure and has to build back up. Eventually it will probably need replacing, but try the marvels for a quick fix.
 

DRanger024

Active member
Joined
Aug 16, 2007
Messages
566
Reaction score
33
Points
28
Location
Dale, WI
Vehicle Year
1994
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Manual
2WD / 4WD
4WD
Total Lift
2" front, stock rear
Tire Size
32X11.50-15
my old 92 Grand Marquis would do that... ended up being dry seals in the heads and also a sticky lifter
 

Wicked_Sludge

New member
Joined
Aug 6, 2007
Messages
6,937
Reaction score
32
Points
0
Age
33
Location
Westport, WA
Vehicle Year
1993
Make / Model
Ford
Engine Size
3-point-GO
Transmission
Manual
sounds like a sticky lifter.

what do you mean by "mis fire code"? EEV-IV doesnt have such a code.
 

kunar

Forum Staff Member
Forum Moderator
Supporting Member
Article Contributor
Joined
Jun 10, 2003
Messages
4,054
Reaction score
55
Points
48
Age
32
Location
Toledo, Ohio
Vehicle Year
1987
Make / Model
Ford
Engine Size
2.3t
Transmission
Manual
probably a sticky lifter...my dads 91 explorer had the same problem, used some oil addative in a yellow bottle and it took away the tick and has been fine since, just change the oil and filter after a few hundred miles to get that crap back out of the system
 

rangernotlifted

New member
Joined
Aug 16, 2007
Messages
210
Reaction score
1
Points
0
Age
29
Location
Belfair
Vehicle Year
1995,1990
Make / Model
jetta,explorer,
Transmission
Manual
what are u talking about mine does that too but mines a 2.9L and as far as im concerned if those fuckers arent ticking then its going to blow, but eh like i say ride it till ti dies then get another motor
 

Hahnsb2

New member
TRS Banner 2010-2011
Joined
Aug 8, 2007
Messages
4,416
Reaction score
36
Points
0
Age
31
Location
Battle Ground WA
Vehicle Year
88-95
Make / Model
Ford-Dodge
Engine Size
4.0-5.2 Turbo
Transmission
Manual
what are u talking about mine does that too but mines a 2.9L and as far as im concerned if those fuckers arent ticking then its going to blow, but eh like i say ride it till ti dies then get another motor
Meh, I disagree. Mines got nearly 240,000 Miles on it now and it only ticks on cold startup.
 

rangernotlifted

New member
Joined
Aug 16, 2007
Messages
210
Reaction score
1
Points
0
Age
29
Location
Belfair
Vehicle Year
1995,1990
Make / Model
jetta,explorer,
Transmission
Manual
hmm thats wierd then because on my motor the injectors tick not really loud bu u can still here it when its running my buddys ranger has a 2.9 in it also and his has about 4000mi on the motor cause he just bought it and it still ticks
 

1985FordRanger

New member
Joined
Oct 3, 2007
Messages
3
Reaction score
0
Points
0
Age
34
Vehicle Year
1985
Make / Model
Ford
Transmission
Manual
My dad has a 93 Mazda b2200 and his ticks on cold start ups also, and when it gets real cold it will sometimes blow blue some till the tick goes away...
 

jamessmith20

New member
Joined
Oct 1, 2007
Messages
5
Reaction score
0
Points
0
Age
34
Vehicle Year
1994
Make / Model
Mazda
Transmission
Manual
sounds like a sticky lifter.

what do you mean by "mis fire code"? EEV-IV doesnt have such a code.
I took it to Midas and the told me i had an O2 sensor and a misfire code, which he said could include dirty injectors, bad coil pac, or plugs and wires. i changed the 02 sensors and the plug and wires and left it in my driveway and now this louder ticking started on startups...
 

AllanD

TRS Technical Staff
TRS Technical Advisor
Joined
Jun 1, 2001
Messages
7,891
Reaction score
103
Points
63
Age
58
Location
East-Central Pennsylvania
Vehicle Year
1987... sorta
Make / Model
Ford
Engine Size
'93 4.0
Transmission
Manual
Midas, Diagnosis? In the same sentance?

Say it ain't so!

Midas just wanted to sell you something.

Having your engine checked for codes by Midas is like having a vasectomy performed by
the checkout clerk at your locak Eckart's

Seek REAL professional help.

AD
 

MAKG

New member
Joined
Aug 7, 2007
Messages
4,634
Reaction score
18
Points
0
Location
California central coast
Vehicle Year
1991
Make / Model
Ford
Engine Size
4.0L
Transmission
Manual
Then you need someone who knows their posterior from a hole in the ground to do your diagnosis.

He got a lean code, which CAN be due to a misfire OR an oxygen sensor OR a dozen other things.

You CANNOT condemn ANY sensor based only on a code.

An excessively rich mixture (due to false lean codes or other problems) can cause tapping by diluting the oil.
 


Top