Mazda B4000 running lean


Rolandtd

New member
Joined
May 1, 2017
Messages
11
Reaction score
0
Points
1
Vehicle Year
98
Make / Model
Mazda
Transmission
Automatic
Hey everyone ive got a lean issue with my mazda b4000 4.0 v6, that has gradually gotten worse. Originally it would surge then bog and if i feathered the gas eventually itd be stable enough to drive but yesterday it gave out completely and would only start and immediately bog out. ive checked codes and originally had p0171 and p0174 which indicated lean. after searching through the forums i checked for vacuum leaks with smoke and starter fluid with no results. Also by looking through the forums i saw something about a pvc elbow from drivers side to pass side but i dont have that line anywhere on mine. today i threw an iac valve at it since i could hear a nice bit of air being pulled through. truck still had the same issue but after keeping it alive with starter fluid it was able to somewhat idle still has a bog under any throttle. after i got it idled i pulled codes and got p0171 p0174 p1130 p1131 p1150 p1151. i figured id post here before tearing the intake off and doing the gaskets to see if someones dealt with this issue.

Also have poked the fuel shrader valve and replaced the fuel filter

thanks in advance for any advice.
 
Last edited:


Rock Auto 5% Discount Code: 57CD9601BD5AB4 Expires: July 1, 2019

Rolandtd

New member
Joined
May 1, 2017
Messages
11
Reaction score
0
Points
1
Vehicle Year
98
Make / Model
Mazda
Transmission
Automatic
Well I've done the intake gaskets and I was still dying. Unplugged maf sensor and it runs so I replaced the maf and still dies when it's plugged up. Anyone to have any ideas?
 

Bigfoot1963

New member
Joined
May 25, 2019
Messages
1
Reaction score
0
Points
1
Location
Las Vegas, NV
Vehicle Year
1998
Make / Model
Mazda B4000
Transmission
Automatic
Check your fuel pressure at the fuel rail, The filter on your fuel pump (in the tank) may be clogged.
 


Top